Okay
  Print

Masonry is broken after updating to Wordpress 3.9

Wordpress 3.9 adds a new masonry version which is not compatible with my theme... and the way I did it before !

open functions.php, then change on line 831

// Masonry : we only register it. It will be added only if it is required 
$masonry = get_template_directory_uri() . '/javascripts/jquery.masonry.min.js'; 
wp_register_script('masonry', $masonry, array('jquery'), '1.0', true);

to

// Masonry : we only register it. It will be added only if it is required 
wp_deregister_script( 'masonry' ); 
$masonry = get_template_directory_uri() . '/javascripts/jquery.masonry.min.js'; wp_register_script('masonry', $masonry, array('jquery'), '1.0', true);

In fact you just need to deregister wordpress loaded version before loading the theme version.

wp_deregister_script( 'masonry' );

It will fix it!

Cheers